PHP Version in WordPress sicher umstellen



Stelle deine PHP Version um, ohne deine WordPress Seite zu crashen!

0:15 Plugins + Themes auf Kompatibilität testen mit
PHP Compatibility Checker (https://de.wordpress.org/plugins/php-compatibility-checker/)
1:45 Erklärung Warning und Error im Compatibility Checker
3:15 Backups machen
3:31 Lokal testen
4:05 PHP bei Mamp umstellen
4:19 PHP bei Live Server (All inkl) umstellen
5:39 nach der Umstellung

Links:

PHP umstellen auf

1&1:
https://hilfe-center.1und1.de/hosting/1und1-webhosting-c10085285/skript–und-programmiersprachen-c10082634/php-c10082686/einrichtung-c10082738/php-version-anzeigen-oder-aendern-a10782429.html

Strato
https://www.strato.de/faq/article/2264/So-aendern-Sie-Ihre-PHP-Einstellungen-in-Ihrem-Hosting-Paket.html

Domain Factory
https://www.df.eu/de/support/df-faq/webhosting/skriptsprachen/php-versionsauswahl/

Alfahosting
https://alfahosting.de/antworten-auf-ihre-fragen/?cid=93#faqContent

11 thoughts on “PHP Version in WordPress sicher umstellen

  1. ich habe die PHP Version beim Host geändert. Aber auf der Website steht immer noch, dass es noch die alte version hat – was tun? dieser Fall ist in dem Video nicht besprochen. Hast du dazu eine Antwort?

  2. Keine Erfahrung mit Update, deshalb hab ich mir die Tutorials angesehen. Kompliment, sehr gut und ausführlich gemacht.
    Z.Zt. verwende ich noch die Version 5.4.45 und wollte das Plugin PHP Compatibility Checker installieren. Ich erhalte jedoch die Info, dass das Plugin nicht kompatibel ist. Was kann ich machen? Wie soll ich vorgehen um von 5.4.45 auf 5.6 upzudaten?

  3. Hallo Maja, ich muss mein php auf 7.4 aktualisieren… leider gab es ein Update mehr von dem Plugin PHP compatibility diese kann ich nur bis 7.3 testen was mein aktuelles php ist. Kennst du eine Alternative? Danke für deine Hilfe!

  4. Bei All-inkl ändert man die PHP Version im Kas Bereich. Mich würde interessieren, ob man vor der Aktualisierung der PHP Version eine Datensicherung (Backup mit zum Beispiel Updraft Plus) durchführen muss!

  5. Hallo Maja,

    Ich habe von meinem webhost die Nachricht bekommen, dass ich meine php version umstellen muss und das auch im htaccess vornehmen muss . Wo kann ich das denn machen? Mache ich das über das htaccess plugin auf WP? Ich kenne mich damit nicht so wirklich aus und habe Angst etwas falsch zu machen. Außerdem kann ich mich auch nicht über die normale login Seite von WP einloggen, sondern nur wenn ich meine URL und dann /wp-admin/ eingebe. Hängt das vielleicht mit dem anderen Problem zusammen? Ich wäre wirklich um jeden Ratschlag dankbar, da ich mich nicht so gut auskenne.

  6. Hilfreich wärs, zu wissen wie man auf die Fehlermeldung reagiert, wenn man nicht rechtzeitig umgestellt hat. ich hatte z.B. ein Projekt, da war per phh-Handler die 5.5 vorgegeben, nachdem allinkl die Seite abgestellt hatte ging natürlich nichts mehr und auch die Umstellung auf php5.6 nutzt nix, weil der Handler ja die alte Version sucht. Da muss man dann halt in der htaccess auf 5.6 umstellen. Alles easy, aber wenn man's nicht weiß 😉

Leave a Reply

Your email address will not be published. Required fields are marked *